Kategori

Matematik

Formüller Matematik

Excelde TOPLA Formülünün Kullanımı

Merhabalar,

Topla fonksiyonu Microsoft Excel’de çok popüler ve kullanışlı bir formüldür.Anlaşılması ve kullanımı en kolay aritmetik formüllerden biridir.

İki Şekilde kullanılabilmektedir.

Kullanımı =Topla(sayı1;sayı2;sayı3;…..;sayıN);

yada

Kullanımı =Topla(Hücre1;Hücre2;Hücre3;…..;HücreN);

Topla Formülü İle İlgili Önemli Noktalar

  • CTRL+M kısayolu ile eklenebilir.
  • Topla formülünde ondalık sayı kullanabilirsiniz.
  • Topla formülünü ilk örnekteki  ( Topla(sayı1;sayı2..) ) gibi kullanırken içerisine sayı dışında karakter eklerseniz “#AD?” hatası verecektir.
  • Topla formülünü ikinci örnekteki  ( Topla(hücre1 ; hücre2 ..) ) gibi kullanırken içerisine sayı dışında karakter içeren bir hücre seçerseniz formül bu hücreyi dikkate almadan toplama işlemini yapacaktır.
  • Topla formülü filtre seçimlerinden etkilenmemektedir.Toplama yaptığınız hücre aralığına filtre uygulandığında da sonuç değişmez.
excelde_topla_formülü
Excelde Topla Formülünün Kullanımı

Yukarıdaki örneklerde TOPLA formülünün farklı kullanımları mevcuttur.Dördüncü örneğimizde hata vermesinin sebebini kısaca açıklamak gerekirse sayı ile metin toplamını yapamadığı için “#AD?” hatası vermiştir, ama hücre toplamı yaparken sayı dışındaki karakterleri dikkate almadan toplama işlemi yapacak herhangi bir hata vermeyecektir.

excelde_topla_formülü
Excelde Topla Formülünün Kullanımı

Yukarıdaki toplama işleminde hücre toplama formülü “=Topla(Hücre1;Hücre2;Hücre3;…..;HücreN)” kullanıldığı için A5 hücresindeki yazı dikkate alınmadan toplama işlemi yapılmıştır.

Hücreye formül yazarak eklenebileceği gibi excel sayfasının sağ tarafında bulunan “Otomatik Toplam” düğmesi ile eklenebilmektedir.Bu Düğmenin altında diğer formülleri(ortalama,en büyük vb) de otomatik olarak ekleyebilirsiniz.

excelde_topla_formülü_eklemek
Excelde Topla Formülü Eklemek

Konuyla ilgili soru ve önerileriniz için iletişim sayfasını kullanabilir yada yorum bırakabilirsiniz.

Yorum Yok
Formüller Matematik

Excelde ETOPLA ve ÇOKETOPLA Formüllerin Kullanımı

Eğer ile Toplam formüllerinin birleşmesi ile meydana gelmiştir.İngilizce isimleri “SUMIF”  ve “SUMIFS” dir.Belirli veri topluluğu içerisinden belirttiğimiz kritere uygun olan verilerin toplamını verir.Aşağıdaki örneklerle formülün çalışma mantığı daha iyi anlaşılacaktır.

1- ETOPLA Formülü

Tek bir kritere bakılarak yapılan toplama işlemin formülüdür.Kullanımı aşağıdaki gibidir.

=ETOPLA (belirtilen kritere bakılacak alan ; kriter ; toplama yapılacak alan)
=ETOPLA(A2:A34;”Turkey”;C2:C34)  >> Bu formülün kontrol ettiği kısım aşağıdaki gibidir.

etopla_formul1

Formülün çalışma yapısı; A sütununda 2. satırdan 34. satıra kadar olan verileri kontrol edip “Turkey” olanların  C sütunundaki karşılıklarını topluyor.

etopla_formul2

 

 

Kriter kısmında özel operatörler kullanabilirsiniz (Örnek “=”, “>”, “<”, “>=”, “<=”, “<>”)

Aşağıdaki örnekte “Turkey ” yazan kısımda özel operatör kullanılarak “Turkey” değerinden farklı olanların toplamı alınmıştır.

etopla_formul3

 

2-ÇOKETOPLA Formülü

ÇOKETOPLA formülünde yukarıda açıkladığımız ETOPLA formülünün tersine bir çok kriter belirtebiliyoruz.

Yukarıdaki örnek üzerinden gidelim.

etopla_formul1

=ÇOKETOPLA(toplanacak alan ; 1. kriterin bakılacağı alan ; 1.Kriter ; 2.Kriterin Bakılacağı alan ; 2.Kriter; 3.Kriterin Bakılacağı alan ; 3. Kriter) şeklinde kaç adet kriter belirtmek isterseniz bu devam ediyor.

** ETOPLA formülünün tersine burada ilk olarak toplanacak alanı belirtiyoruz. **

=ÇOKETOPLA(C2:C34;A2:A34;”Turkey”;B2:B34;”<12.05.2014″)

coketopla_formul1

Yazdığımız formül değeri ” Turkey” olanları ve Date kısmı “12.05.2014” tarihinden küçük olanları topluyor.

Diğer formüller ise sırayla  değeri “Bulgaria”  ve “Egypt” olan ve date kısımları “12.05.2014” tarihinden küçük olanları topluyor.

coketopla_formul2

 

56 Yorumlar

Pin It on Pinterest