Excelde Düşeyara (VLOOKUP) Formülünü Nasıl Kullanırım

Merhabalar,

Düşeyara formülü excel’in en yararlı ve en önemli formüllerinden biridir. Genellikle büyük veriler arasından belirli bir değeri aramak için kullanılır. Orjinal ismi VLOOKUP olan formülün başındaki V “Vertical” yani dikey anlamına gelmektedir.

Düşeyara formülü belirtilen değeri, aramak istediğimiz veri topluluğunun içinde dikey( yukarıdan aşağıya) arar. Bir tek değer aranabileceği gibi çoklu veri araması da yapılabilir.Kullanımı aşağıdaki gibidir.

= DÜŞEYARA (aranan_değer, aranacak_tablo_dizisi, bulunursa_getirilecek_sütunun_numarası, eşleştirme çeşiti)

Düşeyara formülünde ilk olarak aramak istediğimiz veriyi belirtiyoruz,sonrasında bu veriyi nerede arayacağımızı belirtiyoruz,aradığımız değer bulunursa hangi sütunu görmek istiyorsak onun numarasını yazıyoruz,son olarakta tam eşleştirme yada yaklaşık eşleştirme mi olacağını belirtiyoruz.

vlookup_rsm1

Formülde ilk belirtilen kısım yani “A3” kısmı aranacak veri, ikinci kısımda ise “A5:C13”  burası ise aramak istediğimiz verinin bakılacağı yer.Sonraki kısımda 3 ile belirtiğimiz yer ise eğer aradığımız değer bulunursa yazılmasını istediğimiz sütunun sıra numarası, en sonda bulunan “YANLIŞ” yazısı ise aradığımız veri ile tam eşleştirme yapması için.Formülün sonucu aşağıdaki gibidir;

vlookup_rsm2

Formül “Cem”  verisini “Personel” sütununda aradı ve eşleştikten sonra 3 index numarasını verdiğimiz için “Tutar” kısmında bulunan değeri döndürdü bize.

Eğer ki formülde index numarası yerine yani “3” yerine “2” yazdığımız zaman bizde “Ürün Sayısı” sütunundan 16 numarasını getirecektir.


Şimdi biraz daha karışık bir düşeyara formülü yazalım.

vlookup_rsm3

Formülümüz A sütunundaki 1. hücreden 8. hücreye kadar olan verileri Personel tablomuzun isim kısmında arıyor.Eğer ki tam olarak veri eşleşmesi olur ise personel tablosundaki “Ürün sayısı” sütunundaki veriyi döndürüyor.

vlookup_rsm4

A sütunundaki isimler tablodaki sıradan farklı olarak yazılmış ancak düşeyara formülü için herhangi bir sorun oluşturmuyor.B sütunundaki değerleri bulduğumuz formüller yan taraflarına yazılmıştır.

Düşeyara formülünün fazlasıyla kullanım örnekleri mevcut, biz şimdilik giriş seviyesindeki örneklere değindik.İleri zamanlarda daha karmaşık daha büyük verilerin olduğu yazımız olacaktır.

Excelde Düşeyara (VLOOKUP) Formülünü Nasıl Kullanırım” için 19 Yorum Mevcut

  1. Hocam merhabalar,
    Sizin yukarıda yaptığınız örnek üzerinden kendi dosyamda yaptm ancak yalnızca ilk baştaki bir kaç isimleri buluyor sonraki verileri bulamıyor.Ama bulunmayan verileri kendim baktığım zaman bulabiliyorum.Neden olabilir?
    teşekkürler

    1. Merhaba Ahmet Bey,
      Sanırım formülü ilk satıra yazıp aşağı doğru kopyalama yapıyorsunuz.Genelde çok sık karşılaşılan bir hatadır bu.
      Yukarıdaki yazımda en sonda bulunan ekran görüntüsünde mevcut olan kodu aşağıdaki gibi düzenlendim.
      Eğer ki sizde bu şekilde aradığınız veri kısmına yani benim kodumda A1 ve A8 kısmına ve arama yaptığınız yerin hücre numaralarına (benim kodumda A10 ve D18 ) $ işareti koyar ve sonrasında aşağı sütunlara kopyalarsanız diğer verilerinizde bulunacaktır.

      =DÜŞEYARA($A$1:$A$8;$A$10:$D$18;2;YANLIŞ)

      Kolay Gelsin

  2. Hocam ellerinize sağlık 12 sayfalık herbiri 250 kişilik listeyi vermiş olduğunuz bilgiler doğrultusunda 15 dakikada bitirdim. Çok teşekkür ederim. Engin bilgilerinizden dolayı.

      1. Merhaba,

        Uzun bir çek-senet dosyam var. Bunların ay ay ne kadar çek-senedim olduğunu VLOOKUP formölü ile bulmak istiyorum. Yardımcı olabilir misiniz?

  3. merabalar

    tez ödevim için excelden dosya eşleştirmesi yapıyorum.kullandığım veriler 37 bin adet eşleştirmeye çalıştığım veriler ise 62 bin civarı tahmin edeceğiniz üzerine işlem uzun suruyo ve en kısa zamanda bitirmem gerekiyo.bunu nasıl yapıcam bilginiz varmı yukarıdaki verdiğiniz örnek işime yaramıyo sanırım? teşekkürler

  4. Zafer Bey Merhabalar,
    Yukarıdaki örneklerim de formül tüm hücreleri aynı anda arıyor.Sizin dosyanızda olduğu gibi yüksek sayıda veri bulunan ve aranılan metinin,tablonun durumuna göre formülün cevap süresi değişiyor. Bu gibi durumlarda düşeyara formülünü daha performanslı hale getirmek için bazı düzenlemeler yapıyoruz.Örnek olarak ;
    1-) Formüldeki aranan değer kısmını tek hücre olarak belirtiyoruz yani “=DÜŞEYARA(A1:A100;” olan kısmı “=DÜŞEYARA(A1;” olarak değiştiriyoruz ki tek hücre kontrolü yapsın.Formülümüzü aşağı doğru indirdikçe hücre numarasını güncelleyecek.
    2-)Arama kısmını sınırlamak “=DÜŞEYARA(aranan_değer;$B$1:$C$1000 ” şeklinde değiştiriyoruz.
    3-)Bulunduğunda yazılacak sütunu arama yaptığımız yerin bir sağ yanına koymak.Yani aradığımız değer bulunduğunda yazılacak sütunun numarası 2 olmalı.Çünkü 10 sütunu olan bir tablonun en solundaki sütunda arama yapıp aradığımız değer bulunduğunda 9. sütunu yazdırmak istediğimizde aradaki sütunlarda hafızaya alınıyor buda performans kaybına yol açıyor.
    4-) Aranılan değerin olduğu veriler ve arama yapılan verilerin bulunduğu yerlerin tablo olmamasına dikkat edin.

    Yukarıdaki düzenlemelerden sonra formül daha performanslı çalışacaktır.

    İyi Çalışmalar

    1. anladım sağolsun.dünde bu yazdıklarınızı bayağı denedim de sanırım benim elle yapmam gerekiyo işin içinden çıkamadım 🙂 çok teşekkürler sağolsun

      1. Zafer Bey Merhabalar,
        Dosya yapınızı ve verilerinizin yapısını bilmediğim için başka hangi formüller yardımcı olur işlemlerinizde bilmiyorum.Ancak indis ve kaçıncı formülleri ile de düşeyara benzeri sonuçlar elde edilebiliyor.Eğer ki dosyayı gönderme şansınız olursa yardımcı olmaya çalışırım.

        İyi Çalışmalar

        1. çalıştığım dosya bu 20 bine yakın elle eşleştirilmiş hali baktığınızda görüceksiniz 20 binden sonrası yer yer karışık tek tek kontrol ederek bitmiyo 🙁 burada bi kısmı var dosya sınırı olduğu için

          Ek Dosya  Kitap1.xlsx

          1. Zafer Bey Merhabalar,

            Konuyla ilgili adresinize bir mail gönderdim.

            İyi Çalışmalar

  5. Merhaba,
    formülde bir yerlerde hatalı yapıyorum sanırım. email ile dosyayı paylaşsam destek olabilirmisiniz

  6. Selam,
    benim de sizin yardımınıza ihtiyacım var. Benim sorum şu; eğer ki aynı anda iki afet kriterin aranmasını nasıl sağlayabilirim? diyelim ki sipariş numaraları ve bu sipariş numaralarına ait bedenler mevcut. A1 nolu siparişe ait olan S beden ürünlerin toplamını bulmak istiyorum. Şu ana kadar genelde aranan kriterler tek değer oldukları için sorun olmuyordu. bu iki kriteri aynı anda nasıl aratabilirim?

  7. Hocam çok teşekkürler heryerde yazılar var hiçbirşey anlamamış ve yapamamıştım . ancak yazınızdan sonra artık formüllerden korkmuyorum 🙂

  8. merhaba hocam

    benim elimde iki ayrı sayfa var normal düzeşey arada herşeyin aynı olması gerekmekte ama ben sekiz tane kelime yan yana ve içinde birisi bile geçse bulmasını istiyorum nasıl yapabilirim bunu

  9. İyi akşamlar Yılmaz Bey
    =EĞER(A1=1;DÜŞEYARA(M1;sınav1!A5:AF41;2;0); ( M1 Sınavda 1. olanların sınıf sırası var),(A1 ise sınavın nosu) Ara diyorum 1 kişi olunca buluyor. Ancak 1. olan 2 veya daha fazla kişi ise sadece ilk sıradakini alıyor. Tüm 1. leri nasıl listeleyebilirim?

Yorum Yapın