Excelde ETOPLA ve ÇOKETOPLA Formüllerin Kullanımı

Eğer ile Toplam formüllerinin birleşmesi ile meydana gelmiştir.İngilizce isimleri “SUMIF”  ve “SUMIFS” dir.Belirli veri topluluğu içerisinden belirttiğimiz kritere uygun olan verilerin toplamını verir.Aşağıdaki örneklerle formülün çalışma mantığı daha iyi anlaşılacaktır.

1- ETOPLA Formülü

Tek bir kritere bakılarak yapılan toplama işlemin formülüdür.Kullanımı aşağıdaki gibidir.

=ETOPLA (belirtilen kritere bakılacak alan ; kriter ; toplama yapılacak alan)
=ETOPLA(A2:A34;”Turkey”;C2:C34)  >> Bu formülün kontrol ettiği kısım aşağıdaki gibidir.

etopla_formul1

Formülün çalışma yapısı; A sütununda 2. satırdan 34. satıra kadar olan verileri kontrol edip “Turkey” olanların  C sütunundaki karşılıklarını topluyor.

etopla_formul2

 

 

Kriter kısmında özel operatörler kullanabilirsiniz (Örnek “=”, “>”, “<”, “>=”, “<=”, “<>”)

Aşağıdaki örnekte “Turkey ” yazan kısımda özel operatör kullanılarak “Turkey” değerinden farklı olanların toplamı alınmıştır.

etopla_formul3

 

2-ÇOKETOPLA Formülü

ÇOKETOPLA formülünde yukarıda açıkladığımız ETOPLA formülünün tersine bir çok kriter belirtebiliyoruz.

Yukarıdaki örnek üzerinden gidelim.

etopla_formul1

=ÇOKETOPLA(toplanacak alan ; 1. kriterin bakılacağı alan ; 1.Kriter ; 2.Kriterin Bakılacağı alan ; 2.Kriter; 3.Kriterin Bakılacağı alan ; 3. Kriter) şeklinde kaç adet kriter belirtmek isterseniz bu devam ediyor.

** ETOPLA formülünün tersine burada ilk olarak toplanacak alanı belirtiyoruz. **

=ÇOKETOPLA(C2:C34;A2:A34;”Turkey”;B2:B34;”<12.05.2014″)

coketopla_formul1

Yazdığımız formül değeri ” Turkey” olanları ve Date kısmı “12.05.2014” tarihinden küçük olanları topluyor.

Diğer formüller ise sırayla  değeri “Bulgaria”  ve “Egypt” olan ve date kısımları “12.05.2014” tarihinden küçük olanları topluyor.

coketopla_formul2

 

Excelde ETOPLA ve ÇOKETOPLA Formüllerin Kullanımı” için 42 Yorum Mevcut

  1. Merhaba benım sorum şu olacak aynı sütun üzerinde birden çok verinin toplamının alınmasını sağlamak istesek örnek olarak ;

    =çoketopla(c2:c34;a2:a34;”Turkey”;a2:a34″Bulgaria”) dediğimizde Türkiye ve Bulgaristan sayılarının toplamını alamıyorum yardımcı olabilirmisiniz. Şimdiden teşekkürler.

    1. Merhaba Cenk Bey,
      İki yada daha fazla değer için tek satır formülde toplama işlemini aşağıdaki gibi yapabilirsiniz.

      =çoketopla(c2:c34;a2:a34;”Turkey”)+çoketopla(c2:c34;a2:a34;”Bulgaria”)

      İyi Çalışmalar

      1. Yılmaz bey,

        Yardımınız için çok teşekkürler,

        İyi çalışmalar dilerim.

        Saygılarımla.

    1. Merhaba Merve Hanım,

      Hücrelerde bulunan verilerinizin sonlarında boşluk olabilir o yüzden eşleştirme kısmında verdiğiniz değer ile eşleşmediği için sonuç 0 çıkıyordur.

      İyi Çalışmalar

  2. Merhaba,
    Başka bir çalışma sayfasından referansla başka bir çalışma kitabında ÇOKETOPLA ÇOKEĞERSAY formülleriyle veri alıyorum, formüllerin olduğu sayfada bu işlemleri yaptığım hücrelerde #DEĞER hatası alıyorum. Referans sayfayı açtığımda formüller çalışıyor. Sorunu nasıl giderebilirim. Yardımcı olur musunuz?
    Teşekkürler.

    1. Uğur Bey Merhabalar,

      Dış kaynaklara yani sizin yaptığınız gibi farklı bir excel dosyasına bağlı formüllerde iki dosyanın da açık olması gerekiyor aksi durumda formül güncelleştirilemediği için “#DEĞER” hatası verecektir.Bu durumu çözmek için kaynak ve çalıştığınız sayfayı tek bir dosya üzerinde birleştirebilir yada makro yardımıyla çalıştığınız dosyayı açtığınız zaman otomatik olarak kaynak dosyasını da açtırabilirsiniz.

      İyi Çalışmalar

      1. Yılmaz Bey merhaba,
        Verdiğiniz bilgi için teşekkürler.
        A çalışma sayfasına, kendisinden özgün B ve C sayfalarından referans aldığım formüllerin çalışması için makroyu nasıl oluşturabilirim?

        1. Uğur Bey Merhabalar,

          Yalnızca formüllerinizin bulunduğu dosyayı açın.Kaynak dosya kapalı olsun.Sonrasında alt+F11 tuşlarını kullanarak Visual Basic Düzenleyicisini açın.

          Pencerenin üst kısmında bulunan “Insert” düğmesine tıklayıp ardından “Module” düğmesini tıklayın açılan pencereye aşağıdaki kodu kopyalayıp dosya yolunu düzenleyin.Kaynak dosya yolunu tam olarak yazmanız gerekli ( “C:\users\…”) gibi.


          Sub Auto_Open()
          Workbooks.Open (“C:\Users\y.temiz\Desktop\Kaynak_dosya.xlsx”)
          Workbooks(“hedef_dosya.xlsm”).Activate ‘DİKKAT: Burada dosya uzantısı xlsm olarak yazılmıştır
          End Sub

          Kaydet düğmesine tıklayın karşınıza bu dosyada makroları kaydetme ile ilgili bir uyarı çıkacaktır, kaydetme penceresinden dosya biçimini “Makro İçerebilen Excel Çalışma Kitabı” olarak değiştirdikten sonra kaydedebilirsiniz.
          Bu kaydettiğiniz dosyayı her açtığınızda kaynak dosyanızda otomatik olarak açılacaktır.

          İyi Çalışmalar

  3. Merhaba,
    ÇokEtoplada sadece ocak ayı içerisindeki verileri toplamak istiyorum. >=01.01.2015<=31.01.2015 yaptığımda 0 değerini alıyorum. Tarih aralığı nasıl belirtilmelidir.
    Teşekkürler

    1. Vildan Hanım Merhaba,

      Tarih kısımlarını ayrı ayrı yazmanız gerekmektedir.Örnek olarak kontrol edilecek tarihlerin “C” sütununda bulunduğunu varsayalım formülümüz “C2:C12;”>=01.01.2015″;C2:C12;”<=31.01.2015" şeklinde yani tarih için iki kontrol kısmı olmalıdır.İyi Çalışmalar

  4. Yılmaz Bey Merhaba;

    Öncelikle =çoketopla formulü için çok tesekkur ederim okadar işime yaradı ki..yalnız bi problemım var kac adet değişkene kadar destekliyor bu? ben besinci değişkenden sonra alamadım değeri?

  5. Vahit Bey Merhabalar,

    Yazımın yardımcı olmasına çok sevindim. Çoketopla formülü 127 kritere kadar destekliyor.Ancak bu kadar çok kriter verildiği zaman ne kadar sağlıklı ve hızlı çalışır onu test etmek gerekir 🙂 Genelde bu formülde isim karşılaştırmalarında kriter kısmındaki ismin tırnak içerisinde yazılması unutuluyor.İsterseniz bir kontrol edin tekrardan orada bir hata yapmış olabilirsiniz.

    İyi Çalışmalar

  6. Yılmaz Bey Merhaba;

    Arattığım kriter 2016-01, 2016-02……. diye devam edecek fakat almıyor. Suan 4 krıterle çalışıyorum bunu da eklersem süper olacak 🙂 yardımlarınızı beklıyorum.

    Saygılarımla..

  7. Hücrelerin birleştirilip ayrı olması bişeyi değiştirir mi bir de?Suan sonuc aldığım hücreler birleştirimiş şekilde..

  8. Vahit bey Merhabalar,

    İsterseniz dosyayı ek olarak yükleyip gönderebilirseniz formüle bir bakayım.

    İyi Çalışmalar

  9. malesef veri güvenliği gerekçesiyle paylaşamıyorum.ama sorunu hallettim ilginize teşekkur ederim.

  10. Tarih yerine metin girsek nasıl olur birde boşlukta yok 0 çıkıypr sonuç nedendir hocam?

    1. Fikret bey merhabalar,
      Tarih yerine metinde kullanabilirsiniz yalnızca metni tırnak içinde yazmanız gerekiyor aşağıdaki örnek gibi;

      =çoketopla(c2:c34;a2:a34;”Turkey”;a2:a34″Bulgaria”)
      İyi çalışmalar

  11. Fikret bey merhaba
    Ben etopla formülü ile 30 ayrı sayfadaki verileri almak istiyorum yardımcı olabilirseniz sevinirim

    1. Ramazan Bey Merhaba,

      30 ayrı sayfadan veri almak biraz uğraştırıcı olabilir.Eğer ki dosyanızı gönderme şansınız olursa daha kısa yoldan yapabilir miyiz diye inceleyebilirim.

      İyi Çalışmalar

  12. Mesela A1de 01.01.2015 olsun
    B1 de 31.01.2015 olsun
    “C2:C12;”>=A1″;C2:C12;”<=B1”
    Yazdım ama çalışmadı,
    Nasıl bi çözüm bulabilirim yardimci olurmusunuz?
    Teşekkürler şimdiden.

    1. Merhaba Ali Bey,
      Yalnızca Büyüktür ve küçük vb. işaretlerini tırnak içerisinde kullanmanız gerekli hücre adresleri (A1,B2 gibi) tırnak içerisine alındığı zaman formül çalışmamaktadır.Formülünüzü aşağıdaki gibi düzelttiğiniz zaman düzgün hesaplama yapacaktır.

      “C2:C12;”>=″&A1;C2:C12;”<=”&B1"İyi Çalışmalar

  13. Merhaba, bu tabloya bir sütun daha ekleyerek Şehirleri de yazsak, örneğin Türkiye de İstanbul olanların toplamını nasıl alabilirim?
    Teşekkürler

  14. Fuat Bey Merhabalar,
    Yazımın en sonunda bulunan ekran görüntüsündeki örnekte “B” sütununa şehirleri ekleyerek ve formülü aşağıdaki gibi düzenleyerek Turkiye’de İstanbul olanların toplamını alabilirsiniz

    =ÇOKETOPLA(C2:C34;A2:A34;”Turkey”;B2:B34;”İstanbul″)

    İyi Çalışmalar

  15. ÇOKETOPLA DA DOSYALAR ARASI FORMÜL AYARLAYINCA İLGİLİ DOSYADA KAPALI OLUNCA MALESEF SONUÇ VERMİYOR

    1. Serkan Bey Merhaba,

      Evet dosyalar arası çalışan formüllerin sonuç vermesi için iki dosyanın da açık olması gerekiyor.

      İyi Çalışmalar

  16. Merhaba
    Etopla formülünü kullanıyorum. Başka bir excel çalışma kitabından veri alıyorum. Her iki sayfa da açık. Veri aldığım çalışma kitabından tek bir sayfadan veri alınca sonuç geliyor ancak ben o çalışma kitabındaki tüm sayfalardan veri almak istiyorum. Bu şekilde yapınca değer hatası alıyorum.. Formül aşağıda

    Yardımcı olur musunuz?

    =ETOPLA(‘[OCAK RING ÜRETİM.xls]01.02.2016:3.1.2016′!$E$44:$F$48,D3,'[OCAK RING ÜRETİM.xls]01.02.2016:3.1.2016’!$P$44:$P$48)

    :ok teşekkürler

    1. Merhabalar,

      Çalışma dosyanızı örnek olarak gönderebilirseniz daha kolay yardımcı olabilirim.

      İyi Çalışmalar

  17. Merhabalar.

    Bir sorum olacaktı. ETOPLA formülünün içindeki değer kısmına herhangi bir sütun atayabilir miyim. Misal olarak;

    ETOPLA( a1:a100; ” buraya b1 sütunundaki değeri el ile yazarak değil direk sütündan alsın veriyi “, c1:c100)

    1. Merhaba Abdullah,

      Çok kolay bir şekilde değer kısmı yerine bir hücreyi referans gösterebilirsin.Kullanman gereken formül aşağıdaki gibi olmalıdır.

      =ETOPLA( a1:a100;B1;c1:c100)

      İyi Çalışmalar

  18. Merhaba,

    =ÇOKETOPLA(K6:K23;I6:I23;I27;B6:B23;B27<C27) formülü ile b27 hücresinde yazan tarih ile c27 hücresinde yazan tarih aralığının ve diğer kriterin olduğu hücrelerin toplamını almak istiyorum. Ancak birinci kriteri alıyor ikinci kriterde toplamı sıfır veriyor. Yardımcı olabilirseniz sevinirim.

      1. Merhaba Yılmaz Bey,

        Formulü aşağıdaki şekilde revize edince istediğim tarih aralığındaki (B68 1. tarih, C68 2. tarih) ve diğer koşula (I68) uyan toplamı aldırdım. ilginiz için teşekkür ederim.
        =ÇOKETOPLA(K6:K64;B6:B64;”>=”&B68;B6:B64;”<="&C68;I6:I64;I68)

        İyi çalışmalar

  19. Merhaba benim problemim şu şekilde
    B sütununa başka bir sayfadan operatör isimlerini
    C sütununa yine aynı sayfadan operatör yardımcısı isimlerini
    D sütununa da ne kadar iş yaptıklarını aldırıyorum.
    (Beraber çalışan operatör ve yardımcıları aynı satırda yer alıyor.)
    Bu aldırdığım değerleri adı soyadı, yapılan iş olarak hazırladığım aynı sayfada başka bir tabloya aldırmak istiyorum.(Ay olarak toplam yapılan işi).
    Adı soyadı kısmına personelin adını yazdığımda o ayda yaptığım toplam işi bulmasını istiyorum. Çoketopla kullandım ancak bir türlü doğru çalıştıramadım.Yardımcı olabilirseniz çok memnun olurum. Şİmdiden ilginiz için teşekkür ederim

  20. Selamun aleyküm,

    yukarıdaki örnek için Turkey olan ve Mayıs 2014 olan değerlerin toplamını veren formülü yazabilir misiniz?
    çok teşekkür ederim

      1. Eyvallah onu hallettim teşekkür ederim. Peki ülkelere göre sayıların toplamını gösterengrafik gösterimi nasıl yapılır?

        iyi çalışmalar.

  21. ETOPLA çok işime yaradı. anlatım çok iyi video bile gerek kalmamış . emekleriniz için teşekkürler Yılmaz bey sağolun.

Yorum Yapın (Konuyla alakasız yorumlara onay verilmemektedir)