Excelde EĞER Formülünün Kullanımı

Merhabalar,

Eğer formülü Excel’in en çok kullanılan formüllerinden biridir ve iki değer arasında mantıksal karşılaştırmalar yapar.

Eğer formülü kısaca;

=EĞER(Mantıksal karşılaştırma;Karşılaştırma doğru ise buradakini yap;Yanlış ise buradakini yap)

Dolayısıyla EĞER formülünün yalnızca iki sonucu olabilir.Aşağıdaki örneklerle EĞER formülünün çalışma yapısını daha iyi anlayabilirsiniz.

eger_formulunun_kullanimi
Eğer Formülünün Kullanımı

Yukarıdaki örnekte B2 hücresine yazdığımız “=EĞER(A2=”Salı”;”bugün Salı”;”Hayır Salı Değil”)” formül A2 hücresindeki veriyi tırnak içerisinde yazdığımız veriye eşit olup olmadığını karşılaştırıyor.Veriler birbirine eşit olduğu için noktalı virgülden sonra ilk yazdığımız kısım yani “bugün salı” verisini cevap olarak B2 hücresine yazıyor.

NOT:Eğer Formülü BÜYÜK – küçük harfe duyarlı değildir.

eger_formulu_kullanimi
Eğer Formülünün Kullanımı

Yukarıdaki resim de görebileceğiniz gibi formül içerisindeki “salı” günü ile hücredeki “salı” günü büyük ve küçük olarak yazılmıştır.Eğer formülü büyük ve küçük harf yazımına duyarlı olmadığı için formülün karşılaştırması “Doğru” olarak sonuçlanmıştır.

Eğer formülünde sadece metin işlemleri değil matematiksel işlemlerde yapılabilmektedir.Belirlediğiniz koşulun doğru olması durumunda hesaplamalar yaptırabilirsiniz.

NOT: Excel iç içe 64 tane eğer formülünü kullanabilirsiniz.Ancak bu çok tavsiye edilmemektedir.Çünkü çok sayıda iç içe EĞER formülü için kapsamlı şekilde düşünmek ve çok dikkatli yazmak gerekir ve formülün sonuna kadar her koşulda doğru hesaplama yapılacağından emin olmak gerekir.

eger_formulu_kullanimi
Eğer Formülü Matematiksel İşlem

Yukarıdaki örnekte EĞER formülü ile “Aylık Satılan Ürün Miktarı” sütununda bulunan sayıların 25’e eşit veya büyük olduğunu kontrol ediyoruz.Sayı eğer 25’e eşit veya büyük ise formül “DOĞRU” cevabını veriyor,25’den küçük sayılar için “YANLIŞ” cevabını veriyor.

Formülde metin kullanılacaksa “tırnak” içerisinde yazmanız gerekiyor.Ancak formülde özel bir durum mevcuttur(yukarıdaki örnekte görebilirsiniz) DOĞRU ve YANLIŞ kelimeleri için tırnak kullanmanıza gerek yoktur ,Excel bunu otomatik olarak algılar.

=EĞER(C2>=25;DOĞRU;YANLIŞ) > Matematiksel Karşılaştırma

=EĞER(A1=”Salı”;”Bugün Salı”;”Bugün Salı Değil”) Metinsel Karşılaştırma

eger_formul_hesapalama
Eğer Formülü Matematiksel Hesaplama

Yukarıdaki örnekte EĞER formülü “Satılan Ürün Miktarı” sütunundaki sayıları kontrol edip 25’e eşit yada büyük olan sayıların yanındaki “Satış Tutarı” değerini %5 ile çarpıp çıkan sonucu cevap olarak veriyor, “Satılan Ürün Miktarı” sütunundaki sayı 25’den küçük ise formülümüz “YANLIŞ” cevabını döndürüyor.

ic_ice_eger_formulu
İç İçe Eğer Formülü Kullanımı

Daha öncede belirttiğim gibi iç içe EĞER formülü kullanılabilmektedir.Yukarıdaki ekran görüntüsünde iç içe iki adet EĞER formülü kullanılmıştır.

İlk EĞER formülü “Satılan Ürün Miktarı” sütunundaki sayıların 25’den büyük yada eşit olup olmadığını kontrol ediyor.Eğer 25’e eşit yada büyük ise ikinci EĞER formülü için giriyor.İkinci EĞER formülü ise “Satış Tutarı” sütunundaki sayıları kontrol ediyor.Sayılar 1000 değerinden büyük ise %5’i hesaplayıp cevap olarak yazıyor.

İlk EĞER formülünün kontrol ettiği “Satılan Ürün Miktarı” sütunundaki sayılar 25’den küçük ise içeride ki diğer EĞER formülünü hiç kontrol etmeden direk olarak “25’den küçük” mesajını cevap olarak veriyor.İlk EĞER formülünün kontrol ettiği sayı 25’den büyük ise içeride ki ikinci EĞER çalışmaya başlıyor.

Konuyla ilgili soru ve önerileriniz için iletişim sayfasını kullanabilir yada yorum bırakabilirsiniz.

Excelde EĞER Formülünün Kullanımı” için 5 Yorum Mevcut

  1. =EĞER(G2=”B”; “-“;”+”) böyle bi formül yazdım fakat – ya da + olacak değeri nasıl yazacağım yani şöyle bir sutunda sayılarım var diğerinde B/A var B olanlar – olacak A olanlar + ve bunu sayının başına eklemem gerekiyor 1900 tane satır var tek tek yapamam var mı bi çözümü??

  2. Hocam İyi Günler,
    olay: d sütununda dosya numaraları yazılı ve numaraların bir kısmı aynı c sütununda ise isimler bulunmakta, d sütununda ki dosya numaraları aynı olsa bile karşılığında ki c sütununda yazan isimler farklıdır.
    sorun:d sütununda aynı olan bütün dosya numaralarını c sütununda ki isimler ile birleştirmek istiyorum.eğer(b1=b2;birleştir(a1;a2)) yaptım istediği vermedi.Konu ile alakalı iç içe geçen eğer formülü var ise çok yardımı dokunur. Şimdiden ilginize teşekkürler.
    örnek:
    a b formülü istenilen
    ali 2016/193 ali,veli
    veli 2016/193 ali.veli
    yavuz 2016/194 yavuz,yılmaz,ismail
    yılmaz 2016/194 yavuz,yılmaz,ismail
    ismail 2016/194 yavuz,yılmaz,ismail

    1. Yavuz Merhaba,
      İstediğin işlemi özet tablo ile aynı dosya numaralarını gruplayıp ardından yanlarına isimlerini yazdırabilirsin. Sonrasında aynı dosya numarasına sahip isimleri farklı bir sütuna kopyalayıp birleştir formülü ile birleştirebilirsin.Takıldığın yer olursa iletişim sayfasından dosyanı gönderirsen örnek gönderebilirim
      İyi Çalışmalar

Cevapla

E-posta Adresiniz Görünmeyecektir..