Formüller İstatistiksel

Excelde EĞERSAY Formülünün Kullanımı

Merhabalar,

İstatistiksel işlevlerde bulunan EĞERSAY formülü verdiğimiz değerle aynı olan hücre sayısı bulmak için kullanılmaktadır.Örnek olarak bir listede bir şehrin kaç kez geçtiğini bulmak için kullanılmaktadır.

Formülün Yazılışı =EĞERSAY(Arama_Yapılacak_Hücre_Aralığı;Aranacak_Değer)

eğersay_formulunun_kullanımi
Eğersay Formülünün Kullanımı

Yukarıdaki örnekte arama yaptığımız hücre aralığında “Adana” değerini aradık ve sonuç 2 olarak verdi.EĞERSAY formülü büyük küçük harfe duyarlı değildir.
EĞERSAY formülünde joker karakterler kullanılabilmektedir.Örnek olarak “AD” ile başlayan şehirlerin sayısını bulalım.

egersay_formulunde_ozel_karakter
Eğersay Formülünde Özel Karakter Kullanımı

Formülde kullandığımız “AD*” değerinde bulunan yıldız işareti (*), herhangi bir karakteri eşleştirmek için joker karakter olarak kullanılır.”AD” ile başlayan toplam 3 değerimizi mevcuttur.

Aranacak değer kısmında yalnızca metin değil sayı olarak da arama yapabilir , aradığımız değerden büyük yada küçük olanların sayısını bulabiliriz.

Aşağıdaki örneğimizde EĞERSAY formülü sayı karşılaştırmaları için kullanılmıştır.

eğersay_formülünün_sayi_karsilaştirmasi
EĞERSAY Formülünün Sayı Karşılaştırmaları

EĞERSAY formülünde aranacak değer kısmında sayı yada metin kullanırken değerlerimizi ” ” tırnak işareti içine yazıyoruz aksi halde formülümüz hata verecektir.

Aranacak değer kısmında uzun bir metin dizesi(255 karakterden fazla) arattığımız zaman formül hatalı bir değer döndürecektir.

Konuyla ilgili soru ve önerileriniz için iletişim sayfasını kullanabilir yada yorum bırakabilirsiniz.

8 Yorumlar

  • alev

    Bir sorum olacaktı. Cevaplayabilirseniz çok sevinirim.
    Yukarıdaki örneğe göre alışveriş sayısının ortalamasından fazla kaç adet alışveriş yapılmış?

    C14 hücresinde de şöyle bir formül var diyelim ki:
    =Ortalama(C2:C13)

    =eğersay(C2:C13; “>C14”)

    Ancak hata veriyor. C14 ün değerini de başka biryere yazmak istemiyorum görsel açıdan.

    Yanıtla
    • Yılmaz Temiz
      Yılmaz Temiz

      Merhaba Alev,

      Eğersay formülünde yalnızca sayı yada metin kullanırken tırnak içerisine alıyoruz.Yani eğersay formülün aşağıdaki gibi olmalıdır.

      =EĞERSAY(C2:C13;“>”&C14)

      İyi Çalışmalar

      Yanıtla
    • alev

      Merhaba Yılmaz.
      Çok teşekkürler. İyi çalışmalar dilerim.

      Yanıtla
  • vahit

    Merhaba;

    Birleştirilmiş hücrelerde ve farklı sayfalarda eğersay formulunde bir hata alıyorum, sebebi sizce ne olabilir?

    Formul:
    =EĞERSAY((Ocak2016!N5:V133;Subat2016!N5:V143;Mart2016!N5:V231;Nisan2016!N5:V178;Mayıs2016!N5:V152;Haziran2016!N5:V158;Temmuz2016!N5:V99;Ağustos2016!N5:V167;Eylül2016!N5:V157;Ekim2016!N5:V211;Kasım2016!N5:V171);”ABC”)

    Yanıtla
    • Yılmaz Temiz
      Yılmaz Temiz

      Merhaba Vahit,

      Eğersay formülü yazdığın şekilde çoklu hücre aralıklarını desteklemiyor,bu yüzden hata veriyor.

      İyi Çalışmalar

      Yanıtla
  • ENGİN

    Hocam merhaba,

    Puantaj tablomda üç satırım var 1. satır x,off,üi,öi gibi terimlerden oluşuyor ve satır sonu eğersay ile formüller oluşturdum sorun yok çalışıyor ancak tablonun 2 sırasına yukarıdaki eğer say formüllerini kopyalayamıyorum yeniden mi yazmam gerekiyor .Yaklaşık 500 personelim var her biri için ayrı oluşturmaya kalkarsam sanırım emekli olurum 🙂 Lütfen yardımm

    Yanıtla
  • Mehmet tan

    Merhabalar;

    İstatistik formüllerinizi incelediğimde bazı formülleri uygulayamadım. Örneğin sayfa 1 de yazdım ki X firması ürünü A paketi ile 5 sn de paketleniyor. (00:00:05:00), sayfa ikide bunu COKETOPLA ile toparlayamadım, sonuç hep sıfır cıkıyor, hücre biçimlendirmeleri de dahil düzelttim. Ve tüm veriler ayrı ayrı hücrelerde, birleştirme söz konusu değil. Yardımlarınızı beklemekteym.

    Saygılar

    Yanıtla
    • Yılmaz Temiz
      Yılmaz Temiz

      Merhaba Mehmet,
      Verilerin bulunduğu hücreleri detaylı kontrol edersen sorunun çözülebilir,Çünkü çoğu zaman verilerin sonunda fazladan bir boşluk oluyor.Bu sebeple formül aranan veriyi bulamıyor veya eşleşmiyor.

      iyi Çalışmalar

      Yanıtla

Yorum Yap

Pin It on Pinterest