Kategori

Matematik

Formüller Matematik

Excel Düşeyara Formülüne Alternatif Çok Seçenekli Arama-TOPLA ÇARPIM

Excel Düşeyara Formülüne Alternatif Topla.Çarpım Formülü

Merhabalar Herkese,
Uzun zamandır kurumsal ve bireysel işlerin yoğunluğundan dolayı yeni yazı yazamıyordum ama tabi ki gelen maillere olabildiğince cevap yazmaya çalıştım.
Bu salgın hastalıktan dolayı evde zaman geçirdiğim için yeni bir yazı yazmanın tam zamanı diye düşündüm ve buradayım 🙂

Excel kullanan arkadaşların iyi bildiği Excel Düşeyara formülü üzerine daha öncesinde iki adet yazım mevcut.(Onlara aşağıdaki linklerden ulaşabilirsiniz)
Excelde Düşeyara (VLOOKUP) Formülünü Nasıl Kullanırım
Excelde Düşeyara(VLOOKUP) Formülünün Detaylı Örnekleri

Excel düşeyara formülünün normal kullanımı sırasında yalnızca bir seçenek için arama yapabiliyoruz. Evet bu şekilde işimizi görse de öyle zamanlar oluyor ki bir kaç seçenekli arama yapmamız gerekiyor.

İşte bu nokta da düşeyara formülüne alternatif olarak TOPLA.ÇARPIM formülünü kullanacağız.

İlk olarak TOPLA.ÇARPIM formülünü kısaca tanıyalım.

=TOPLA.ÇARPIM(dizi;dizi1;dizi2….) şekilde yazılmaktadır.Burada ki dizi tanımlamasını grup olarak da adlandırabiliriz.

Topla.çarpım formülünde, birbirlerine karşılık gelen verilerin çarpımlarının toplamını verir. Varsayılan olarak yapılan işlem çarpma işlemidir, ancak toplama, çıkarma ve bölme de mümkündür.

Örnek olarak aşağıdaki işlemde kullandığımız formülümüz de =TOPLA.ÇARPIM(A1:A2;B1:B2) iki adet dizi tanımladık A1’den A2’ye birinci dizi, B1’den B2’ye ikinci dizi olarak.

Topla.Çarpım formülümüz ilk olarak 2 ile 5 sayılarını çarptı ,ardından ikinci sıradaki 5 ile 3 sayıları çarptı ve çıkan sonuçları toplayarak sonucu bizlere verdi.

excel-topla-carpim-formulu-kullanimi
excel-topla-carpim-formulu-kullanimi

Formülün biraz daha anlaşıldığını düşünüyorum.Şimdi asıl yapmak istediğimiz can alıcı yere gelelim. Düşeyara formülüne alternatif olarak TOPLA.ÇARPIM formülünü nasıl kullanacağız.

=TOPLA.ÇARPIM((H2=B2:B12)(H5=E2:E12)(D2:D12)) Aşağıdaki örnekte kullanmış olduğum formül bu şekildedir.

Formülü parça parça incelersek eğer; “H2=B2:B12” H2 hücresinde yazan veriyle aynı olan veriyi B2 ile B12 hücreleri arasında arıyor. Aynı uygulamayı H5 hücresinde bulunan veri içinde E2 ile E12 hücreleri arasında arıyor.

Bu iki arama sonrasında eğer veriler bulunabildiyse ve sıraları eşleşiyorsa son olarak D2 ile D12 arasında bu verilerin bulunduğu satırı sonuç olarak getiriyor bize.

excel-topla-carpim-formulu-kullanimi-ornek
excel-topla-carpim-formulu-kullanimi-ornek

Burada gerekli kriterlere uyarak aranan veri sayısını istediğimiz kadar tanımlayabiliriz.

Konuyla ilgili soru ve önerileriniz için iletişim sayfasını kullanabilir yada yorum bırakabilirsiniz.

Diğer yazılarımıza göz atmayı unutmayın

Sağlıklı günler

Yorum Yok
Formüller Matematik

Excelde ETOPLA ve ÇOKETOPLA Formüllerin Kullanımı

Excel’de Eğer ile Toplam formüllerinin birleşmesi ile meydana gelmiştir.İngilizce isimleri “SUMIF”  ve “SUMIFS” dir.Belirli veri topluluğu içerisinden belirttiğimiz kritere uygun olan verilerin toplamını verir.Aşağıdaki örneklerle formülün çalışma mantığı daha iyi anlaşılacaktır.

1- ETOPLA Formülü

Tek bir kritere bakılarak yapılan toplama işlemin formülüdür.Kullanımı aşağıdaki gibidir.

=ETOPLA (belirtilen kritere bakılacak alan ; kriter ; toplama yapılacak alan)
=ETOPLA(A2:A34;”Turkey”;C2:C34)  >> Bu formülün kontrol ettiği kısım aşağıdaki gibidir.

etopla_formul1

Formülün çalışma yapısı; A sütununda 2. satırdan 34. satıra kadar olan verileri kontrol edip “Turkey” olanların  C sütunundaki karşılıklarını topluyor.

etopla_formul2

Kriter kısmında özel operatörler kullanabilirsiniz (Örnek “=”, “>”, “<”, “>=”, “<=”, “<>”)

Aşağıdaki örnekte “Turkey ” yazan kısımda özel operatör kullanılarak “Turkey” değerinden farklı olanların toplamı alınmıştır.

etopla_formul3

2-ÇOKETOPLA Formülü

ÇOKETOPLA formülünde yukarıda açıkladığımız ETOPLA formülünün tersine bir çok kriter belirtebiliyoruz.

Yukarıdaki örnek üzerinden gidelim.

etopla_formul1

=ÇOKETOPLA(toplanacak alan ; 1. kriterin bakılacağı alan ; 1.Kriter ; 2.Kriterin Bakılacağı alan ; 2.Kriter; 3.Kriterin Bakılacağı alan ; 3. Kriter) şeklinde kaç adet kriter belirtmek isterseniz bu devam ediyor.

** ETOPLA formülünün tersine burada ilk olarak toplanacak alanı belirtiyoruz. **

=ÇOKETOPLA(C2:C34;A2:A34;”Turkey”;B2:B34;”<12.05.2014″)

coketopla_formul1

Yazdığımız formül değeri ” Turkey” olanları ve Date kısmı “12.05.2014” tarihinden küçük olanları topluyor.

Diğer formüller ise sırayla  değeri “Bulgaria”  ve “Egypt” olan ve date kısımları “12.05.2014” tarihinden küçük olanları topluyor.

coketopla_formul2

Konuyla ilgili soru ve önerileriniz için yorum bırakın

Bu yazı 09 Mart 2020 tarihinde güncellenmiştir.

72 Yorumlar
Formüller Matematik

Excelde TOPLA Formülünün Kullanımı

Merhabalar,

Topla fonksiyonu Microsoft Excel’de çok popüler ve kullanışlı bir formüldür.Anlaşılması ve kullanımı en kolay aritmetik formüllerden biridir.

İki Şekilde kullanılabilmektedir.

Kullanımı =Topla(sayı1;sayı2;sayı3;…..;sayıN);

yada

Kullanımı =Topla(Hücre1;Hücre2;Hücre3;…..;HücreN);

Topla Formülü İle İlgili Önemli Noktalar

  • CTRL+M kısayolu ile eklenebilir.
  • Topla formülünde ondalık sayı kullanabilirsiniz.
  • Topla formülünü ilk örnekteki  ( Topla(sayı1;sayı2..) ) gibi kullanırken içerisine sayı dışında karakter eklerseniz “#AD?” hatası verecektir.
  • Topla formülünü ikinci örnekteki  ( Topla(hücre1 ; hücre2 ..) ) gibi kullanırken içerisine sayı dışında karakter içeren bir hücre seçerseniz formül bu hücreyi dikkate almadan toplama işlemini yapacaktır.
  • Topla formülü filtre seçimlerinden etkilenmemektedir.Toplama yaptığınız hücre aralığına filtre uygulandığında da sonuç değişmez.
excelde_topla_formülü
Excelde Topla Formülünün Kullanımı

Yukarıdaki örneklerde TOPLA formülünün farklı kullanımları mevcuttur.Dördüncü örneğimizde hata vermesinin sebebini kısaca açıklamak gerekirse sayı ile metin toplamını yapamadığı için “#AD?” hatası vermiştir, ama hücre toplamı yaparken sayı dışındaki karakterleri dikkate almadan toplama işlemi yapacak herhangi bir hata vermeyecektir.

excelde_topla_formülü
Excelde Topla Formülünün Kullanımı

Yukarıdaki toplama işleminde hücre toplama formülü “=Topla(Hücre1;Hücre2;Hücre3;…..;HücreN)” kullanıldığı için A5 hücresindeki yazı dikkate alınmadan toplama işlemi yapılmıştır.

Hücreye formül yazarak eklenebileceği gibi excel sayfasının sağ tarafında bulunan “Otomatik Toplam” düğmesi ile eklenebilmektedir.Bu Düğmenin altında diğer formülleri(ortalama,en büyük vb) de otomatik olarak ekleyebilirsiniz.

excelde_topla_formülü_eklemek
Excelde Topla Formülü Eklemek

Konuyla ilgili soru ve önerileriniz için iletişim sayfasını kullanabilir yada yorum bırakabilirsiniz.

Yorum Yok

Pin It on Pinterest