Formüller Matematik

Excel Düşeyara Formülüne Alternatif Çok Seçenekli Arama-TOPLA ÇARPIM

Excel Düşeyara Formülüne Alternatif Topla.Çarpım Formülü

Merhabalar Herkese,
Uzun zamandır kurumsal ve bireysel işlerin yoğunluğundan dolayı yeni yazı yazamıyordum ama tabi ki gelen maillere olabildiğince cevap yazmaya çalıştım.
Bu salgın hastalıktan dolayı evde zaman geçirdiğim için yeni bir yazı yazmanın tam zamanı diye düşündüm ve buradayım 🙂

Excel kullanan arkadaşların iyi bildiği Excel Düşeyara formülü üzerine daha öncesinde iki adet yazım mevcut.(Onlara aşağıdaki linklerden ulaşabilirsiniz)
Excelde Düşeyara (VLOOKUP) Formülünü Nasıl Kullanırım
Excelde Düşeyara(VLOOKUP) Formülünün Detaylı Örnekleri

Excel düşeyara formülünün normal kullanımı sırasında yalnızca bir seçenek için arama yapabiliyoruz. Evet bu şekilde işimizi görse de öyle zamanlar oluyor ki bir kaç seçenekli arama yapmamız gerekiyor.

İşte bu nokta da düşeyara formülüne alternatif olarak TOPLA.ÇARPIM formülünü kullanacağız.

İlk olarak TOPLA.ÇARPIM formülünü kısaca tanıyalım.

=TOPLA.ÇARPIM(dizi;dizi1;dizi2….) şekilde yazılmaktadır.Burada ki dizi tanımlamasını grup olarak da adlandırabiliriz.

Topla.çarpım formülünde, birbirlerine karşılık gelen verilerin çarpımlarının toplamını verir. Varsayılan olarak yapılan işlem çarpma işlemidir, ancak toplama, çıkarma ve bölme de mümkündür.

Örnek olarak aşağıdaki işlemde kullandığımız formülümüz de =TOPLA.ÇARPIM(A1:A2;B1:B2) iki adet dizi tanımladık A1’den A2’ye birinci dizi, B1’den B2’ye ikinci dizi olarak.

Topla.Çarpım formülümüz ilk olarak 2 ile 5 sayılarını çarptı ,ardından ikinci sıradaki 5 ile 3 sayıları çarptı ve çıkan sonuçları toplayarak sonucu bizlere verdi.

excel-topla-carpim-formulu-kullanimi
excel-topla-carpim-formulu-kullanimi

Formülün biraz daha anlaşıldığını düşünüyorum.Şimdi asıl yapmak istediğimiz can alıcı yere gelelim. Düşeyara formülüne alternatif olarak TOPLA.ÇARPIM formülünü nasıl kullanacağız.

=TOPLA.ÇARPIM((G2=B2:B12)(G5=E2:E12)(D2:D12)) Aşağıdaki örnekte kullanmış olduğum formül bu şekildedir.

Formülü parça parça incelersek eğer; “G2=B2:B12” G2 hücresinde yazan veriyle aynı olan veriyi B2 ile B12 hücreleri arasında arıyor. Aynı uygulamayı G5 hücresinde bulunan veri içinde E2 ile E12 hücreleri arasında arıyor.

Bu iki arama sonrasında eğer veriler bulunabildiyse ve sıraları eşleşiyorsa son olarak D2 ile D12 arasında bu verilerin bulunduğu satırı sonuç olarak getiriyor bize.

excel-topla-carpim-formulu-kullanimi-ornek
excel-topla-carpim-formulu-kullanimi-ornek

Burada gerekli kriterlere uyarak aranan veri sayısını istediğimiz kadar tanımlayabiliriz.

Konuyla ilgili soru ve önerileriniz için iletişim sayfasını kullanabilir yada yorum bırakabilirsiniz.

Diğer yazılarımıza göz atmayı unutmayın

Sağlıklı günler

6 Yorumlar

  • Avatar
    hasan antalyalı

    hocam h2 ve h5 diye yazdıgınız yerlerı g2 ve g5 seklınde duzeltır mısınız

    Yanıtla
  • Avatar
    hasan antalyalı

    “….Varsayılan olarak yapılan işlem çarpma işlemidir, ancak toplama, çıkarma ve bölme de mümkündür.”” demişssiniz.hocam buna da bir örnek verebılır mısınız.ornegın çıkarma işlemi yapsın.

    Yanıtla
    • Yılmaz Temiz
      Yılmaz Temiz

      Merhaba Hasan,
      TOPLA.ÇARPIM formülü ile çıkarma işleminin kullanımı aşağıdaki formülde olduğu gibi yapılmaktadır.

      =TOPLA.ÇARPIM((A1:A2)-(B1:B2))
      İyi Çalışmalar

      Yanıtla
  • Avatar
    Muharrem Yılancı

    Merhaba ; Sayfa1,Sayfa2,Sayfa3 (Örnek: Her sayfada Sırayla (Sıra No ,Tarih,Ürünün Adı ,Stok Adeti ) Sıra Numarası Sayfa1 de sabit 1 olarak verilecektir , Sıra Numarası Sayfa2 de sabit 2 olarak verilecektir. Yapılmak istenen Sayfa1 ve Sayfa2 dekileri Sayfa3 te Sıra Numarasını sabit alarak 1.satıra Sayfa1 deki verileri , 2.satıra Sayfa2 deki verileri versin , her satırda bu sıraya göre tekrarlasın

    Yanıtla
  • Avatar
    soner apaydın

    hocam selam

    =EĞER(Sayfa1!$A$1=”27.01.2021″;”Sayfa2!$C$2″;Sayfa2!$C$2)

    bu satırı otomatik kopyalamak istiyorum, ama sadece tarih ilerlemeli?

    yöntemi var mıdır?

    teşekkürler

    Yanıtla

Bu Yorumu Cevapla Yılmaz Temiz İptal

Pin It on Pinterest