Arşiv

Formüller Matematik

Excelde ETOPLA ve ÇOKETOPLA Formüllerin Kullanımı

Excel’de Eğer ile Toplam formüllerinin birleşmesi ile meydana gelmiştir.İngilizce isimleri “SUMIF”  ve “SUMIFS” dir.Belirli veri topluluğu içerisinden belirttiğimiz kritere uygun olan verilerin toplamını verir.Aşağıdaki örneklerle formülün çalışma mantığı daha iyi anlaşılacaktır.

1- ETOPLA Formülü

Tek bir kritere bakılarak yapılan toplama işlemin formülüdür.Kullanımı aşağıdaki gibidir.

=ETOPLA (belirtilen kritere bakılacak alan ; kriter ; toplama yapılacak alan)
=ETOPLA(A2:A34;”Turkey”;C2:C34)  >> Bu formülün kontrol ettiği kısım aşağıdaki gibidir.

etopla_formul1

Formülün çalışma yapısı; A sütununda 2. satırdan 34. satıra kadar olan verileri kontrol edip “Turkey” olanların  C sütunundaki karşılıklarını topluyor.

etopla_formul2

Kriter kısmında özel operatörler kullanabilirsiniz (Örnek “=”, “>”, “<”, “>=”, “<=”, “<>”)

Aşağıdaki örnekte “Turkey ” yazan kısımda özel operatör kullanılarak “Turkey” değerinden farklı olanların toplamı alınmıştır.

etopla_formul3

2-ÇOKETOPLA Formülü

ÇOKETOPLA formülünde yukarıda açıkladığımız ETOPLA formülünün tersine bir çok kriter belirtebiliyoruz.

Yukarıdaki örnek üzerinden gidelim.

etopla_formul1

=ÇOKETOPLA(toplanacak alan ; 1. kriterin bakılacağı alan ; 1.Kriter ; 2.Kriterin Bakılacağı alan ; 2.Kriter; 3.Kriterin Bakılacağı alan ; 3. Kriter) şeklinde kaç adet kriter belirtmek isterseniz bu devam ediyor.

** ETOPLA formülünün tersine burada ilk olarak toplanacak alanı belirtiyoruz. **

=ÇOKETOPLA(C2:C34;A2:A34;”Turkey”;B2:B34;”<12.05.2014″)

coketopla_formul1

Yazdığımız formül değeri ” Turkey” olanları ve Date kısmı “12.05.2014” tarihinden küçük olanları topluyor.

Diğer formüller ise sırayla  değeri “Bulgaria”  ve “Egypt” olan ve date kısımları “12.05.2014” tarihinden küçük olanları topluyor.

coketopla_formul2

Konuyla ilgili soru ve önerileriniz için yorum bırakın

Bu yazı 09 Mart 2020 tarihinde güncellenmiştir.

74 Yorumlar
Kısayollar

Excelde Hızlı ve Kolay Çözümler

Excel Uzmanlığımız İle Yanınızdayız

İş dünyasında en çok kullanılan yazılımların başında gelen Microsoft Excel, kullanmış olduğunuz neredeyse tüm programlar ile entegre edilerek birlikte çalışabilir, veri alışverişi yapabilir.

Microsoft Excel’i kullanan insanların yalnızca çok az bir kısmı belli başlı özellikleri dışında tam anlamı ile kullanmaktadır. Aslında Excel kendi içinde “programlama” yapabilme yeteneğine sahip Microsoft ürünüdür. Kısa adı VBA (Visual Basic for Application) desteği ile Excel  yapılması çok fazla vakit alabilecek çalışmalarda sizlere çözümler üreterek yapılacak işlerinizde fazlasıyla zaman kazandırır.

excelde-raporlar
Excelde Raporlar

Bu zamana kadar geliştirdiğimiz projeler ile müşterilerimizin işlerini hızlandırdık ve esneklik sağladık.Bu kazançlar ile kaybettikleri zamanlarını nakite çevirdik.

Sizleri de Excel ve VBA yetenekleri ile tanışmaya bekliyoruz.

excel-hocam-VBA
Excel Hocam VBA

Excel-VBA Ne Fayda Sağlar

♦ Excel’de hazırlamaya çalıştığınız raporları hızlı ve kolay yapabilir.
♦ Kullanıcı dostu arayüzlerle müdahale esnekliği sağlar.
♦ Excel VBA ile tasarlananlar projeler açık kaynak kodlu olduğundan,istenilen fonksiyonlar kolayca eklenip çıkarılabilir.
♦ İstenilen bir çok adımı tek tuşa bağlı bir komut ile kendi yapar. (Farklı Kaynaklardan Veri al, Düzenle, Rapor Haline Getir, Raporu Özetle,Mail Oluştur,Gerekli Kişileri Ekle ve Gönder,Kopyasını Yazdır, vb.. )
♦ Dış veri bağlantıları kurabilir. Veritabanlarında, Web Sayfalarından, XML Sorgularından, Farklı Excel Dosyalarından, Access, Csv, Word ve çok daha fazla kaynaktan veri okuyarak istediğiniz şekilde düzenleyebilir.
♦ Çalıştığınız çok verili karmaşık dosyalardan özet raporlar ve göze hitap eden grafikler üretebilir.
♦ Bütçe planlamaları, nakit akım grafikleri, durum raporları, çek, banka ve muhasebe işlemleriniz ile ilgili takipleri  kolayca yapabilmenize yardımcı olur.
♦ İşletmenizdeki cihazlarla entegre haline gelerek cihazdaki verileri okur, size özel sonuçlar, raporlar üretir.
♦ İşlerinize ve size bağlı olarak saymakla bitiremeyeceğimiz konularda sizlere kolaylıklar sağlar.

2 Yorumlar

Pin It on Pinterest